[SeaBIOS] [PATCH 0/9] Misc boot related cleanups

Gleb Natapov gleb at redhat.com
Wed Dec 29 20:00:36 CET 2010


On Wed, Dec 29, 2010 at 12:46:45PM -0500, Kevin O'Connor wrote:
> Some cleanups I came across while reviewing the boot code.
> 
> Gleb - patch 7 conflicts with your last patch - I hope it isn't a big
> deal to fixup though.  (I'm still reviewing your last patch.)
> 
The remaining patch is pretty independent. Should be very easy to rebase.
Do you want me to do it?

> -Kevin
> 
> 
> Kevin O'Connor (9):
>   Rename add_ordered_drive() to add_drive() and use in map_hd_drive().
>   Call setup_translation() from map_hd_drive().
>   Don't access drive_g->desc from boot_cdrom().
>   Remove Drives global struct in favor of independent global variables.
>   Move IPL.checkfloppysig to a global (CheckFloppySig) in boot.c.
>   Move IPL.bev to static variables in boot.c
>   Move IPL.fw_bootorder to static variables in boot.c.
>   Minor reorganization of some of the boot_xxx code in boot.c.
>   Remove drive->desc field.
> 
>  src/ahci.c       |   40 +++++++---------
>  src/ata.c        |   41 +++++++---------
>  src/block.c      |   64 ++++++++++++-------------
>  src/boot.c       |  137 +++++++++++++++++++++++++++++++-----------------------
>  src/boot.h       |   36 +-------------
>  src/cdrom.c      |    2 +-
>  src/coreboot.c   |    5 +--
>  src/disk.c       |    2 +-
>  src/disk.h       |   13 +----
>  src/floppy.c     |   28 ++++++-----
>  src/output.c     |   26 ++++++++++
>  src/ramdisk.c    |   10 +++-
>  src/usb-msc.c    |   32 ++++++-------
>  src/util.h       |    2 +
>  src/virtio-blk.c |   11 ++---
>  15 files changed, 221 insertions(+), 228 deletions(-)
> 
> -- 
> 1.7.3.4

--
			Gleb.



More information about the SeaBIOS mailing list