[SeaBIOS] Boot ordering problem with qemu-kvm / seabios / gPXE

Gleb Natapov gleb at redhat.com
Thu Sep 29 17:27:55 CEST 2011

On Thu, Sep 29, 2011 at 11:30:08AM +0200, Romain Vrignaud wrote:
> We see the right bootindex option as I want to boot on gPXE from my second
> NIC (mac=52:54:00:28:ca:e6).
> The problem is that during my VM boot process, seabios initialise gPXE for
> my 2 NIC.
> But then gPXE try to boot (DHCP request) on the first NIC rather than on the
> second one.
> It always try to boot first on the first PCI device (00:03.0 instead of
> 00:04.0).
> I don't really know if the problem comes from gPXE or Seabios but I have
> exactly the same problem when I try with Ubuntu's etherboot rom.
It is likely gPXE problem. If the option rom found on the first card
initializes both rtl cards it finds instead of only the one it was
loaded from then bootindex will not work correctly. Can you try with
two different nic models (rtl8139 and e1000 for instance) and see if
boot order works correctly for you?
> I got this problem with Ubuntu latest qemu-kvm
> (0.14.1+noroms-0ubuntu3.11.04.1) / seabios (0.6.2-0ubuntu1) and etherboot
> (5.4.4-7ubuntu2) and Fedora qemu-kvm (qemu-kvm-0.15.0-4.fc15.x86_64) /
> Seabios (seabios-bin-0.6.2-2.fc15.noarch)  and gPXE
> (gpxe-roms-qemu-1.0.1-4.fc15.noarch).
> I also recompiled latest Seabios (pre-0.6.3-20110929) trunk and gPXE
> (1.0.1+) from Git : the behaviour is exactly the same. I tried with
> different NIC driver (virtio and rtl8139) with also same behavior.
> Do you have any idea where my problem can come from ?
> Thanks in advance for any advice.
> Regards,
> Romain Vrignaud

> _______________________________________________
> SeaBIOS mailing list
> SeaBIOS at seabios.org
> http://www.seabios.org/mailman/listinfo/seabios


More information about the SeaBIOS mailing list